Sensors, Electronics and Prototyping

firmware update

  • This topic has 6 replies, 3 voices, and was last updated 7 years ago by Naveen.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #820

    can anyone exlpain step by step how I can update the firmware of the um7 ?
    I also got its expansion board.
    I downloaded the new version(U71D) and I tried to upload it to sensor via chr serial interface and software connects to sensor but when I tried to upload firmware its disconnect and gives “device unavailable. is the bootlader activated” I used commands menu “get firmware revision” but nothing changes.


    To update the firmware, use the following steps:

    1) Download the newest firmware HEX file from here:
    2) Make sure you have the latest version of the Serial Interface, available here:
    3) Connect the BOOT pin on the UM7 to the 3.3V pin before applying power.
    4) Power up you UM7. The LED should *not turn on. This means that the bootloader started in programming mode.
    5) Make sure that your UM7 is appropriately connected to your computer. The USB Expansion Board is a good way to do so.
    6) Open the Serial Interface and select the correct COM port. Do NOT click “Connect.” Select the firmware HEX file you downloaded in step 1 and click “Program.” It should flash the new firmware. Once it finishes, disconnect the BOOT pin and cycle power. You are finished!


    Mr. Caleb
    I didnt exactly understand how I can do the “3) Connect the BOOT pin on the UM7 to the 3.3V pin before applying power.”
    could you please show it with an image coz I dont want to do anything wrong to my sensor that can damage it. (I got USB Expansion Board )
    thanx for your help


    no help? just a sketch is also enough…


    There is a pinout diagram on page 12 of the UM7 datasheet, available here:

    Connect the pin labeled BT0 to the pin labeled 3.3V, on the bottom-right connector shown in the diagram.


    thank you so much.


    The device is being detected as USB serial port on COM6 in my deveice manager which is also visible in the Redshift Serial interface. However, upon trying to connect to the AHRS, I get the following errors successively.
    “Received packet with bad checksum. Packet discarded.
    Error: Timeout while communicating with sensor.”
    Note: The LEDs on the UART to USB and on the AHRS are lit.

    Further, I tried communicating with the AHRS with Matlab serial communication and i did succeed in getting the data but along with a lot of crap. A sample of the data is as follows:


    Any help in this regard will be greatly appreciated.

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘UM7 Product Support’ is closed to new topics and replies.